SPREADSHEETS

(Data for this tutorial at www.peteraldhous.com/Data)

Spreadsheets are great tools for sorting, filtering and running calculations on
tables of data. Journalists who know the basics can “interview” data to find
stories and trends that others may miss. In this tutorial, we will work with
LibreOffice Calc, which you can download from here.

Once you know your way around a spreadsheet, it’s fairly easy to pick up the
skills needed to work with many other tools for data analysis.

TIP! Whenever you get some new data, save it under a new name! Then
if you mess things up, you can always go back to the original.

So, let’s open the file City Budget.xls, available online here, by selecting
File>Open and save it under a new name by selecting File>Save As.

Formatting, basic calculations and sorting

Spreadsheets use a simple co-ordinate system, with letters for columns and
numbers for rows. You can make calculations on data using these
coordinates.

This data was provided some years ago to a reporter working on a small city
paper.

1. Formatting data

First, let’s format the columns as currency. Select columns B and C by
clicking on the letters while pressing Ctrl (Windows) or command (Mac);
then select Format > Cells from the top Menu; when the dialog box pops
up, select Currency, USD $ and 0 decimal places.


http://www.peteraldhous.com/Data
http://www.peteraldhous.com/Data/City%20Budget.xls
https://www.libreoffice.org/download/libreoffice-fresh/
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1 Departmenr This year |Next year | Format Cells
2 CityCounck 105,207 95,452 FROWEEE™] = — - - - -
3 City Clerk 70.778 75234 . Font  Font Effects | A\ggnmem | Borders | Background Cell Protection |
4 City Managr 182,540 190,321 Category Format Language
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6 Personnel 191,116 195,400 ek USD § English (USA) Default - English (USA
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So, now we have everything in $, but we still can’t see everything in column
A, so let’s format the column width.

Click the square at the top left, which selects all the data in the sheet. Then
Format>Column>Optimal Width and OK at the next dialog box.

TIP! If ever you see a column containing ###, it contains a number that is
wider than the column. Use the same trick to fix the problem.

2. Performing basic calculations
Now let’s calculate how the budget has changed from last year to this year.
All calculations start by entering = into the cell. So, the formula for first cell

is =(C2-B2).

(At this stage, we may need to format the cells in the column so that they are
alsoin $.)



Move the cursor to the bottom right hand corner of the cell until you see it
change to a cross, then double click. Calc autofills the column, performing
the same calculation for each row until it hits a space.

TIP! Calc can recognize other patterns in your data and autofill in the same
way. To number a list of records, for instance, type 1, 2, 3, into the first three
cells next to a column of data, select those three cells and autofill.

You can also Copy (Ctrl-C or command-C) the first cell and Paste (Ctrl-V
pr command-V) all the way down the column. See how the “marching ants”
form around the cell you’ve copied.

(This will give Os where the cells are blank, and #VALUE! errors as Calc
tries to perform a calculation on text. These can simply be deleted.)

TIP! You can lose your work if you later delete data that was used to
calculate values that you are still working with. If this is a possibility, Copy
the calculated data and paste it into a new column by selecting Edit>Paste
Special and selecting Numbers, Text etc, as appropriate.



So let’s do that here:
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1 Departments This year
2 |City Council $105,207
3 |City Clerk $70,778
4 | City Manager $182,540
5 |Municipal Court $195,645
6 |Personnel $191,116
7 |Planning and Community Development $305,607
8 |Fire Department $2.456,789
9 | Police Department $3,101,345
10 |Public Works $2,156,987
11 |Community Services $85,654
12 |General City Fund $1,234,823
13 | Parks and Recreation $1,400,400
14 |Health $1,033,188
15
16 _Tntals $12,520,079
17
18
19 |Revenues This year
20 |General Property Taxes $2,500,234
21 |Sales Taxes $3,967,138
22 |Other local taxes $2,623,456
23 Licenses and permits $264,675
24 |Fees and Service Charges $330,345
25 |Revenue From Other Sources $1,096,345
26 |Building Rentals $188,000
27 |Miscellaneous $158,782
28 |Interest $1,231,209
29 |Fines $234,645
30
31 |Totals $12,594,829
32

You may need to format our new column to currency once more. See how
the cells now contain the numbers, not the formulas used to calculate them.
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Then delete the old column D by selecting the cells, then Edit>Delete Cells.



Now let’s calculate the percentage change in budget, rather than the absolute
$ value.

The formula for the first cell is:
=((C2-B2)/B2) or =(D2/B2).

So enter this, and copy down the column as before. Again, you may need to
format to have the results displayed as a percentage, rather than a decimal.

3. Sorting data

Let’s sort by % change. To do so, highlight the range of data you want to
sort, then select Data>Sort. When the dialog box pops up, select Sort key
1> % Change and check Descending order.

TIP! When sorting, make sure Calc has recognized that your data has a
header row if there is one present, otherwise that will be sorted as well. Look
under the Options tab in the Sort dialog box and if necessary check Range
contains column labels.

TIP! Make sure when sorting to select the full range of data you want to
sort, and no more. Missing rows or columns from sorts, or including
extraneous data are common ways to scramble your data. Use Edit>Undo if
you make a mistake. In this case we want to sort separately on the
Departments and Revenues tables, Taking care not to include the Totals.
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1 |Depar1mems |Thi5 year Next year Difference % change

2 City Council $105,207 $95,452 -89,755 -9.27%

3 City Clerk $70,778 $75,234 $4,456 6.30%

4  City Manager $182,540 $190,321 $7,781 4.26%

5 Municipal Court $195,645 Sort

6 Personnel $191,116 [ISSRGHERaN Options |

7 Planning and Community Development $305,607| gort key 1

8 Fire Department $2,456,789 Ascending
9  Police Department $3,101,345 % change > Descariding
10 Public Works $2,156,987

11 Community Services $85,654| Sy Mool
12 General City Fund $1,234,823| |- undefined - . cending
13 Parks and Recreation $1,400,400 Descending
14 Health $1,033,188 Sort key 3 ‘
L - undefined - 2} Ascenaing
16 |Totals $12,520,079 Descending
17
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19 |Revenues This year

20 |General Property Taxes $2,500,234

21 |Sales Taxes $3,967,138

22 |Other local taxes $2,623,456

23 |Licenses and permits $264,675

24 |Fees and Service Charges $330,345

25 |Revenue From Other Sources $1,096,345 oK Cancel Help Reset
26 |Building Rentals $188,000

27 |Miscellaneous $158,782 $162,234 $3,452 2.1?%.

28 |Interest $1,231,209 $1,323,456 $92,247 7.48%

29 |Fines $234,645 $250,786 $16,141 6.88%

30

31 |Totals $12,594,829 $13,331,663 $736,834 5.85%
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Sorting by % change and Diftference, for both Departments and Revenues
can produce ideas for story angles. What might the reporter have pursued in
this case?

TIP! Always check any calculations that you haven’t done yourself
The mantra of journalism should be: if your mother says she loves you,
check it out! We should be as skeptical of numbers as we are of human

sources. So let’s just check that the totals we were given add up correctly.

To check the Total for This Year, Departments, the formula is
=SUM(B2:B14).

Now Copy this cell, and Paste into columns C and D. What’s our reporting
plan now?

Ry



4. Performing anchored calculations

In each calculation we’ve performed so far, we’ve moved down or across the
spreadsheet performing the equivalent calculation for that row or column.
But sometimes that isn’t what we want to do.

Let’s calculate the increase in revenue from each source as a percentage of
the total increase in revenue.

Use the formula:

=(D20/$D$31), and then autofill.

The $ signs anchor the calculation. To anchor to a specific cell, you need a $
in front of both coordinates.

Importing data, filtering, subtotals and pivot tables

Now we’re going to look at a larger dataset, used in reporting this story
about the drug company Pfizer's payments to doctors, to show how you can
use a spreadsheet to drill down to selections from the data, and to perform
useful summary calculations.

Data is often provided as text (.txt) or comma separated values (.csv) files,
so we’ll first learn how to import a text file into Calc.

TIP! Databases should always be able to export data as .txt or .csv files, so
bear this in mind whenever an organization says it can’t provide data
because it’s in a special format.

1. Importing a text file
Find the file Pfizer payments.txt, available online here, and open it in a text
editor See that individual entries are separated by Tabs and some of the

entries are surrounded by double quote marks.

Open a new document in Calc by selecting File>New>Spreadsheet. Then
select Insert>Sheet From File.


http://www.peteraldhous.com/Data/Pfizer%20payments.txt
http://www.newscientist.com/article/dn18806-revealed-pfizers-payments-to-censured-doctors.html

Browse for the file Pfizer payments.txt and open it. Fill in the dialog box as
follows:

Untitled 1 - LibreOffice Calc
E-B FEE T B2 @il &0 wE &
Arial 10 B A4 A % i el P [H-E-gQ-
Al &L= ~
A B C D E F G H 1 J K L M N 7
% T Text Import - [Pfizer¥%20payments.txt]
3 | Import e
g Character set Unicode (UTF-B)
Cancel
g Language Default - English (USA)
9
H | From row 1 Help
%% : Separator options
E { Fixed width
%g | Separated by
%g | Tab Comma Other
S? | Semicolon Space
g% Merge delimiters Text delimiter
24 !
25 Other options
26
27 Quoted field as text
2
gg Detect special numbers
30
31 | Fields
32
gi Column type
gg Standard Standard Standard Standard
37 1 Organizaticon/individual First name plus Last name City
38 2 3-D MEDICAL SERVICES LLC  STEVEN 3RUCE DEITELZWEIG NEW ORLEANS
39 3 A2 DOCTORS, INC. ARKASH MOHAN RHUJA PAS0 ROBLES
2? 4 RBBO, LILIAN MARGARITA LILIAN MARGARITA ABBO MIAMT
42 5 RBBO, LILIAN MARGARITA LILIAN MARGARITA ABBO MIAMI
43 6 REBO, LILIAN MARGARITA LILIAN MARGARITA ABBO MIAMI
44 7 BB H RAFFEE MD PC ABDULLAH RAFFEE FLINT
gg 8 RBERE, SHEILA Y SHEILA ¥ ABEERE INDIANAPOLI!
47
i . -
50
51
52

Click OK at the next dialog box, and the data should import.

Format the columns as desired, making the last three currency, and the
header row bold.

TIP! To keep the header row present when you scroll through the
spreadsheet, select the row beneath it and then select Window>Freeze.

Save this file as Pfizer payments, and then again under a new name, by
selecting File>Save As. You can save as an ODF spreadsheet, or in Excel
format.



Notice that we have a list of more than 10,000 payments, which in this form
doesn’t tell us very much.

2. Filtering data

So let’s set up the spreadsheet so we can filter for what we’re interested in.
Let’s say we want a list of all doctors in California who were paid $10,000
or more to run expert-led forums.

Select the entire spreadsheet be clicking the square at top left, then select
Data>Filter>Standard Filter, and fill in the dialog box as follows:

Standard Eiltar

Filter criteria

Operator Field name Condition Value
State = CA
AND Category = pert-Led Forums
AND Total >= 10000
- none - =
More Options ¥ Help OK Cancel

Click OK, and you should have a list of 31 doctors.

For this filter, we connected the Filter criteria by AND operators, which
ensured that rows were selected only if all the stated criteria were met.
Filters obey Boolean logic; see what happens if you replace the first AND
with OR.

TIP! If you need to keep, or do further calculations on a filtered subset of
the data select the data, Copy it and Paste into a new worksheet. To rename
the sheet for future reference, right click on the sheet tab and select Rename
Sheet

Select Data>Filter>Remove Filter to return to the entire spreadsheet.


http://www.ithacalibrary.com/sp/subjects/boolean

3. Calculating subtotals

Let’s now find out how much money went to each state. Select
Data>Subtotals and fill in the dialog box as follows:

fais

Subtot
m 2nd GrcuR _ 3rd Grou_p_ _ [_)_ptions ;

Group by
State

Calculate subtotals for
Organization/individual
First name plus
Last name
City
State
Category
Monetary payment
Non-monetary payment
Total

Use function

Sum

Count

Average

Max

Min

Product

Count {(numbers only)
StDev (Sample)
StDevP (Population)
Var (Sample)

VarP (Population)

OK Cancel Help Reset Delete

Click OK, and then click on the 2 at top left to hide the data and just leave
the subtotals (1 hides everything except the grand total.)

Notice that we added together the totals by state using the function Sum, but
we could have used other functions to aggregate the data in other ways.

Select Data>Subtotals>Delete to clear the subtotals.



4. Making pivot tables

What if we want to know subtotals by state and by category of payment? We
can do that in one step, using a pivot table.

Select Data>Pivot Table>Create, click OK at the initial dialog box, and
then drag and drop in the dialog box as follows:

Layout

OK
Organizat...
Page Fields First nam... Cancel
Last name Help
C City
ategory
State Remove
Column Fields
Category
Options...
Monetary ...
State Sum - Total Non-mon...
Total
Row .
Fields Data Fields
More ¥

Drag the fields into the desired position.

Notice that the calculation for Totals has defaulted to Sum, which is what we
want, but we can select other aggregate functions by double clicking on Sum
— Total.

Click OK, and the pivot table will be inserted into a new sheet. Format the
column widths as necessary.



The final pivot table should look like this:
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Filter
[Sum - Total Category I=1
State Business Related Tr liems __Expor-Led Forums Initiaiod P Moals Piizer Sponsored Res* Plizer Sponsored Res P Advising_(empty) Total Result
[pic §1,750 51,750
(AL $29,123 8431 $128,850 55,837 510217 $278,485 566,096 5110560 s681,639
) 53,783 5318 572,825 53,700 577,670 52,636 $160,934
sz $15,101 5173 $134,600 576,102 513,409 5225615 $107,79 568,872 $641,851
ca 524,827 5947 1,480,650 $173,563 $156,716 §1,125,624 $328,149 $1,243,531 54,737,807
co 518,207 s144 $176,550 512,433 8506,437 S111,4867 £915,23
cT 520,747 578 504,325 50,133 5252213 580,000 5185785 $632,284
oc $31,008 $48,500 $7,774 $22,371 $140,798 $250,541
bE 52,861 5135 840,425 31,344 3622 38,500 $53,987]
FL 587,865 5405 $525,875 541,187 574,806 $306,600 $1,267,809 5259410 $2,564,047
GA 539,915 $252,800 525410 $180,632 57,500 5112368 561,64
I 55,834 $21,200 $3,338 36,247 $6,000 $42,617]
Iy 57,025 s78 $58,225 84,871 $32,207 $123,375 520,125 $243,70¢)
o 53,617 520,725 51,064 512,250 $37,65
m $1,465 $341,775 $80,000 538,810 $393,395 §79,922 $260,236 $1,256,82
IN 5291 $145,375 515,018 $19,876 53,333 $135,886 $349,589
ks 5210 589,025 57,566 §7,442 §117,220 568,970 $307,20
Iy 5228 595,650 54,530 59,707 $211,385 54,800 586,354 $436,93
La 5463 $158,875 $14,575 $21,171 547,018 $261,921
A $154,675 $129,500 521,498 795,327 856,673 51,764,771
D 500 5134,367 580,280 §17,202 5301,499 5203,757 $870,30
ME $15.225 $1,249 5500 18,731}
1 5235 $298,925 585,266 526,190 $258,748 $184,966 $239,015 $1,146,28
N $47 5185,036 511,527 5155,672 $181,071 $569,30
Mo 8517 $331,950 518,002 5225788 584,411 S278,616 $973,58¢
S 5345 350,750 36,111 $14,500 585,27
T 8,100 5485 $11,20
NG 531 §534,150 538,475 1,205,370 $167,818 5321819 E $2,320,43
ND $15,825 5200 $16,14
NE 367,300 82,772 $108,242 51,071 514,249 $200,25
INH 510,375 53,245 536,348 512,999 $172,369
N s409 5269,625 539,425 $137,154 51,500 $130,805 $600,842
i 524,700 $18,750 $1,683 $5,000 $1,500 $9,825 563,830
v 5135 546,000 52,932 520,325 §73,024
Ny 5508 572,992 584,138 585,004 532,747 $630,535 $2,065,04]
oM 5744 $362,625 §18,734 542,908 $213,955 $200,966 §1,019,4.
oK 5242 572,250 84,087 11,753 519,787 511,529
orR 555,000 84,105 5186,490 545322 $303,74
Pa $357 $301,300 $150,778 544,034 §1,271,285 $15,944 $636,824 52,484,50
PR 591,775 511,460 $19,464 $1,825 $130,334
RI 525,250 38,494 5104,420 §19,000 538,840 $210,204
sc 5101,275 570,041 511,798 5159,177 65,107 $421,491
so s78 $20,150 $1,773 $3,750 529,509
[Ty 8325 $353,200 831,186 $136,401 $177,786 5115204 £849,22
13 $1,985 5680,125 5302,641 570,976 §1,013,070 56,000 5585,211 52,802,194
T 591,650 511,000 57,856 5224,997 527,180 $380,89

A 385 $127,625 $22,000 515,344 385,648 53,000 590,004 $367,937
T 5,000 5242 521,653 $20,889

A 5184 5145,100 515470 589,007 537,732 580,990 $396,06¢

| $570 $188,500 57,400 $13,405 520,075 558,625 $510,122

369,675 $0,483 38,749 528,679 $128,373
534,325 51,308 52,300 $39,96:

(Total Result 31892329 312322 52.643.220 Sl441855 5272419 $11.137.574 S2.800.911 S0.364131 sl 535370 ZE_SI




