MAKING MAPS WITH GOOGLE FUSION TABLES

(Data for this tutorial at www.peteraldhous.com/Data)

Thanks to Google Fusion Tables, creating maps from data and embedding
them on a web page is now easy.

We’re going to make this map, illustrating the number of globally threatened
amphibian species by freshwater ecoregion, superimposed with the location
of sites deemed important for amphibians, designated under the international
Ramsar Convention on wetlands conservation.

First we need to be logged in at Google Drive (https://drive.google.com/)
with a Google account.

Make the thematic map of threatened species by ecoregion

When mapping to commonly-used boundaries, such as US states, Fusion
Tables will recognize the names and match them to the correct area. But in
other cases, such as this, you first need a map defining the boundaries.

Geographical data exists in two common formats: Shapefiles and KML.

Shapefiles are a format used in Geographic Information Systems (GIS)
software. They consist of a series of files, one of which (with the
extension .dbf) is a table of data. Shapefiles can be obtained from various
sources; here’s a good general library:
http://www.naturalearthdata.com/downloads/. They are usually available
online as compressed (zipped) folders.

KML is the data format used by Google Earth.

TIP! When searching for shapefiles, try adding “shapefile” or “GIS data” to
your search terms. To find KML, use Google’s Advanced Search, and
select .kmz (the compressed form of KML) or .kml (try both).

If you need to upload a shapefile to Fusion Tables, go to
http://shpescape.com/ and upload the zipped folder. KML will upload to
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Fusion Tables directly. If your download was a KMZ file, first open it in
Google Earth, right click on the file in Places, and save as KML.

We don’t need to upload boundary data, however, because that’s already
been done by The Nature Conservancy, when it used Fusion Tables to create
this series of maps. In fact, a version of the map we’re going to make is
already at this site — but we’re going to go through the steps needed to join
data on threatened amphibians to the boundaries.

Open the freshwater ecoregion boundary data (at
https://www.google.com/fusiontables/data?
docid=1gjGiTQAH2gFwQmbL2SfXMSKNXx wVYImodurLg). You
should see a screen like this:

Freshwater Ecoregions Table for Merges

Click File | About for Metadata

File Edit Tools Help Rows 1~ | Bfcards 1 9 Map of geometry

+
No filters applied Not saving

4 4 1-1000f 12,176 >

eco_id geometry ge... ECO_ID ECOREGION MHT_TXT MHT_NO oLD_ID ECO_ID_U Shape_Leng Shape_Area OR... MH... im...

101 kml... 32 101.000000  Alasken palar 11 55.000000 30101 347.666769 188.543459 44 5
Coastal freshwaters

101 kml... 33 101.000000  Alasken POl 11 55.000000 30101 347.666769 188.543459 44 5
Coastal freshwaters

101 kml... 10 101.000000  Alasken polar 11 55.000000 30101 347.666769 188.543459 44 5
Coastal freshwaters

101 kml... 24 101.000000  Alasken pole 11 55.000000 30101 347.666769 188.543459 44 5
Coastal freshwaters

101 kml... 8 101.000000 ~ Aaskan polar 11 55.000000 30101 347.666789 188.543450 44 5
Coastal freshwaters

101 kml... 10 101.000000  Alaskan EEE 11 55.000000 30101 347.666789 188.543459 44 5
Coastal freshwaters

101 kml.. 21 101.000000  Alasken polar 11 55.000000 30101 347.666789 188.543459 44 5
Coastal freshwaters

101 kml.. 208 101000000  Alasken EEE 11 55.000000 30101 347.666789 188.543459 44 5
Coastal freshwaters

101 kml.. 8 101.000000  Alasken polar 11 55.000000 30101 347.666789 188.543460 44 5
Coastal freshwaters

You can click on the arrows on the blue circles above the table at top left to
scroll across to see the other columns in the table, most of which we don’t
need.

Notice the columns ECOREGION, which gives the name of each,
MHT _ TXT, which is a description of the ecoregion type, geometry, which
is the column the map will be drawn from, and eco_id, which is an
identifying number for each region. We’ll use these later.
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The data giving the number of globally threatened amphibians in each
ecoregion is in the spreadsheet threatened amphibians.xlsx.

Open this spreadsheet in Excel, and note that the first three columns match
up with those we saw in the boundary data table. Now Sort on the column
thrtd_amph from largest to smallest.

A B C D E F
1 leco_id  ECOREGION MHT_TXT MHT_NO thrtd_amph
2 312 Amazonas High Andes montane freshwaters 3 95
3 301 North Andean Pacific Slopes - Rio s tropical and subtropical coastal rivers 8 94
4 302 Magdalena - Sinu tropical and subtropical upland rivers 9 63
5 765 Middle Yangtze temperate upland rivers 6 43
3 715 Western Ghats tropical and subtropical coastal rivers 8 37
7 518 Southern Gulf of Guinia Drainages tropical and subtropical coastal rivers 8 37
8 201 Chiapas - Fonseca tropical and subtropical coastal rivers 3 35
9 203 Mosquitia tropical and subtropical coastal rivers 8 33
10 305 Orinoco High Andes montane freshwaters 3 33
11 519 Western Equatorial Crater Lakes montane freshwaters 3 a3
12 202 Quintana Roo - Motagua tropical and subtropical coastal rivers 3 32
13 171 Papaloapan tropical and subtropical coastal rivers 8 29
14 304 South America Caribbean Drainage tropical and subtropical coastal rivers 8 29
15 807 Eastern Coastal Australia temperate coastal rivers 5 29
16 505 Lower Niger - Benue tropical and subtropical floodplain rivers and wetland complexes 10 28
17 173 Grijalva - Usumacinta tropical and subtropical coastal rivers 8 26
18 206 Chirigui tropical and subtropical coastal rivers 8 26
19 205 San Juan (Nicaragua/Costa Rica)  tropical and subtropical coastal rivers 8 25
20 581 Madagascar Eastern Highlands montane freshwaters 3 25
21 204 Estero Real - Tempisque tropical and subtropical coastal rivers 8 23
22 174 Upper Usumacinta tropical and subtropical upland rivers 9 23
23 763 XiYiang tropical and subtropical floodplain rivers and wetland complexes 10 23
21 165 Lerma - Chapala xeric freshwaters and endorheic (closed) basins 4 22
25 766 Lower Yangtze temperate floodplain rivers and wetlands 7 22

Note that the maximum value is 95. Scroll down to the bottom, and you’ll
also see that some of the regions with 0 threatened amphibians are those for
which there is No Data. Indeed, if you look at TNC’s map, you’ll see that 0
in the thrtd_amph column actually means “None or insufficient data.”

Tip! Always examine your data, and do background research so you’re
aware of its quirks and limitations.

We will later use the column eco_id, with the identifying numbers for the
ecoregions, to join the data in the spreadsheet to the ecoregion boundaries.



Back in your Google Drive account, import the spreadsheet by selecting
Create>Fusion Table (experimental).

At the first dialog box, select From this computer, and hit Choose File:

Import new table
]' From this computer | Choose File | No file chosen

You can upload spreadsheets, delimited text files (.csv, .tsv, or xt),
E Google Spreadsheets and Keyhole Markup Language files (kml) Learn more

b Create empty table

Or search public data tables

New to Fusion Tables? Cancel Next »
Take a peek! Play with a data set or try a tutorial.



Select the spreadsheet, click Next, and again at the second dialog box:

Import new table

Column names are in row | 1

2

Rows before the header row will be ignored.

eco_id

312

301

302

765

7156

518

New to Fusion Tables?
Take a peek! Play with a data set or try a tutorial.

ECOREGION
Amazonas
High Andes

MNorth Andean
Pacific Slopes
- Rio Atrato

Magdalena -
Sinu

Middle
Yangtze
Western Ghats

Southern Gulf
of Guinia
L T

MHT_TXT

montane
freshwaters

tropical and
subtropical
coastal rivers

tropical and
subtropical
upland rivers

temperate
upland rivers

tropical and
subtropical
coastal rivers

tropical and
subtropical

bl e —

MHT_NO

Cancel

thrtd_amph
95

94

68

43

3v

37

« Back | Next»

If you wish, you can edit the table name and add more information at the

third dialog box, then click Finish and it should load.



Now we will join our spreadsheet to the ecoregion boundaries. Still in the
uploaded spreadsheet, select File>Merge from the top menu. In the Merge:
Select a Table dialog box, paste the url for the freshwater ecoregion
boundaries table into the box labeled Or paste a web address here and hit
the Next button.

Fusion Tables may recognize that we want to join using the eco_id columns,
but you can change the columns selected if necessary:

Merge: Confirm source of match

This table Freshwater Ecoregions Tabl...
eco_id - eco_id -
312 101
301 101
302 101
765 101
715 101
518 101
20 101
203 101
305 101
519 101

Matching values in these two columns will create the merged table. Learn more

Click Next.



We don’t need all of the data across the two tables, so at the next dialog box
we’ll select the columns we need. First click on none to remove all the
check marks, and then recheck just the columns we need, shown below. In
this view columns from the threatened amphibians spreadsheet are on a
white background, while those from the freshwater ecoregions boundary
data are shaded yellow:

Merge: Choose columns

All ~ Q,

18 columns

Select all none

# eco_id
ECOREGION
MHT_TXT
MHT_NO

# thrtd_amph

# geometry
geometry_vertex_count
ECO_ID

 ECOREGION

# MHT_TXT

Click Merge and at the next dialog box then click View table.



Now we can start mapping. Click on the Map of geometry tab. If you get a
blank gray screen, click and drag it down until the map appears. Initially,
you’ll see a series of points, but zoom in a little and the boundaries will
appear:

Merge of threatened amphibians and Freshwater Ecoregions Table for Merges
Click File | About for Metadata.

File Edit Tools Help ‘ = Rows 1 ‘ HE Cands 1 ‘ ? Map of geometry ~ ’T‘

m No filters applied

Click the Change info window ... button from the panel at the left. This is
where we will define what appears when the map is clicked. Here’s what it
looks like without editing:

eco_id: 602

thrtd_amph: 0
ECOREGION: Ob
MHT_TXT: polar freshwaters




In the Automatic tab, uncheck eco_id, as we don’t want this field to appear.
Then select the Custom tab and edit the html code. For example, here we’ve
changed the order of the entries, tidied up the field names, and added some
line breaks using html <br> tags:

Change info window layout

Automatic Custom

Write the HTML for your info window with column placeholders like {celumn name}. Learmn more

eco_id <div class="googft-info-window’ style='font-family: sans-serif'>
<b=Ecoregion:</b> {ECORECION}<br=<br>

thrtd_amph <b>Type:</b> {MHT_TXT}<br=<brs>

geometry {?év_ﬂloballvthreatened amphibian species:</b> {thrid_amph}i<br>
</div>

ECOREGION

MHT_TXT

Save Cancel

Hit the Save button.



Now we’ll color the regions according to the number of threatened species.
Click the Change feature styles ... button, select Polygons>Fill color, and
select the Buckets tab.

In this tab, Divide into 6 buckets and select thrtd_amph as the Column to
map. It’s worth experimenting with the number of buckets and the splits
between them to give the best display for your data. In this case we’ll follow
TNC’s example, and edit the dialog box as follows:

Change map styles

Points
Polygon background colors
Marker icon
Fixed Column Buckets Gradient
Polygons -
Fill color

i@ Divide into | Custom = | buckets
Border color

m

Border width Column | thrtd_amph -
Lines + 0.0 up to 1.0 - it
Line color
. . + |- 1.0 upto 3.0 -
Line width
+|1-] 3.0 upto 8.0 -
= | - |8.0 up to 16.0 -
+| |- [16.0 up to 31.0 . -
=| - |31.0 up to 895.0 -
95.0 i

Save Cancel



Then we can select a color scheme. In this case, we’ll select a neutral gray
for the first bucket, because zero can also mean “insufficient data,” then use
one of Google’s suggested color schemes for the other buckets. Select 75%
for opacity so the colors stand out nicely from the Google map.

Change map styles

Points
Polygon background colors
Marker icon
Eixed Column Buckets Gradient
Polygons E—
Fill color

Border color (=) Divide into | Custom = buckets

Border width Column | thrtd_amph +
Lines . 0.0 up to 1.0 -

Line color

Line width 4 1= 1.0 up to 3.0 5
+][-] [3.0 up to 8.0 E
+||=-| [B.O up to 16.0 #76a5af
)88 Jwwosto | T T T
V1310 Jwwesoe |IET T

95.0
m Cancel

Opacity |75 B




Hit the Save button, and here is the thematic map:

Merge of threatened amphibians and Freshwater Ecoregions Table for Merges m

Click File | About for Metadata.

File Edit Tools Help | =Rowst | HfCamdst | 9 Map of geometry - h

m No filters applied Saved 12,176 rows

| Map | Satelite |

Before we can embed the map on a website, we need to make it visible to the
wider world by clicking the Share button at top right. At the dialog box click
on the Change link, select Public on the web and click Save and then
Done.

Next select File>About this table and cut and paste the table’s Id into a
word processing document or text file — we’ll consider the significance of
this later.



Make the map of points showing Ramsar Convention sites

The data is in the file ramsar amphibian sites.csv. (It was downloaded
from the Ramsar Sites Database.)

Upload the file to Fusion Tables as before, filling the first dialog box as

follows (setting Character encoding to auto-detect should ensure that
accents and other unusual characters will appear correctly):

Import new table

| From this computer Choose File | ramsar amphi...n sites.csv
Separator character (s) Comma () Tab () Colon () Other
ﬂ Google Spreadsheets Character encoding | auto-detect
”‘ Create empty table You can upload spreadsheets, delimited text files (.csv, .tsv, or .bxt),
and Keyhole Markup Language files (.kml) Learn more

Or search public data tables

New to Fusion Tables? Cancel Next »

Take a peek! Play with a data set or try a tutorial.



http://ramsar.wetlands.org/Database/Searchforsites/tabid/765/Default.aspx

The uploaded table should look like this:

ramsar amphibian sites

File Edit Tools Help = Rows1~ | BfCards 1 % Map of Latitude —|
N
m Mo filters applied
4 4 11000f315 B »

Site name Designation date Latitude Longitude Total...
Réserve Intégrale  44,4/1983 36.88333333 8.516666667 2700
du Lac Tonga
Marais de la 2/2/2001 35.68333333 0.166666667 44500
Macta
Oasis de
Tamantit et Sid 2/2/2001 2775 025 95700
Ahmed Timmi
Petit Loango 30-12-1986 23 0.616666667 480000
Setté Cama 30-12-1986 _2.716666667 10.08333333 220000
Ain Elshakika 5/4/2000 3276666667 21.35 33
Ain Elzarga 5/4/2000 32.78333333 22.35 50
Merja Zerga 20-06-1980 34.85 6.266666667 7300
Baie de Khnifiss 20-06-1980 28.05 225 20000
Parc national du 30-04-1987 12.25 2.416666667 220000
0 . .

g‘{;f“'e? Nature 7/7/1998 24,65 287 3970
ene
Parc national des | 45 ¢ 1g0g 5.75 12.75 66000

Mangroves



Unfortunately, the format in the Designation date column is not consistent,
but we can fix that. Select Edit>Change columns, and change the format:

Change columns

Table Columns Column Details
Site name Text Column name:

Designation date Designation date

Latitude Location Type:
) Date/Time = |
Longitude Mumber S '
Format:
Total site area (ha) Mumber
Bes 003

Save || Cancel



The points will be mapped by their Latitude and Longitude, so we’ll also
check that Fusion Tables has recognized that location is specified by these
columns. If not, change to the following:

Change columns

Table Columns Column Details
Site name Text Column name:
Designation date Date/Time Latitude
Latitude Type:

5 Location -
Lengitude MNumber
Format:
Total site area (ha) Number

| None s |

™ Two column location:

Latitude: Latitude

Longitude: | Longitude

Save || Cancel



Finally, change the number format for the site area so that thousands are
separated by a comma, which will make large numbers easier to read:

Change columns

Table Columns Column Details
Site name Text Column name:
Designation date Date/Time | |1otal site area (ha)
Latitude Location Type:
\ Mumber
Longitude MNumber
Format:
Total site area (ha)
1,234.56 -

Save | Cancel

Hit Save, and then Map of latitude from the top menu. The points should
appear on the map.



Click Change info window ... Under the Automatic tab, uncheck Latitude
and Longitude, then under the Custom tab we can again edit the html as

desired:

Change info window layout

Automatic Custom

Write the HTML for your info window with column placeholders like {column name)}. Leam more

Site name
Designaticn date
Latitude

Longitude

Total site area (ha)

Save Cancel

Hit the Save button.

<div class="googft-info-window’ style="font-family: sans-serif'>
<b>5ite name:</b> {5ite name}<br><br>

<b=Designation date: < /b= {Designation date}<br><br=
<b>Total site area:</b> {Total site area (hal} heactares

</{div>



Click Change feature styles ..., and under Points>Marker icon, select the
small yellow dot, for a good contrast with the previous map:

Change map styles

Points )
Map marker icons
Marker icon
Fixed Column Buckets
Polygons
Fill colaor

@ Use one icon
Border color

O -
Border width

Lines
Line color
Line width

Save Cancel

Hit the Save button.

As before, click Share button at top right. At the dialog box click on the
Change link, select Public on the web and click Save and then Done.

Then select File>About this table and again cut and paste the table’s
Encrypted ID into your word processing document or text file.



Make a web page with both maps

To do this, we will use the Fusion Tables Layer Wizard.

Go back to the finished map of the ecoregions, select Tools>Publish and
copy the first of the two links that appears. Then paste that link into the
Embed link box in the Wizard and click the Put layer on Map button. The
map should appear in the Preview:

1. Add map layers Preview

The table needs to be accessible and exportable.

P e —————
Embed link https:/ fwww.google.c|

Copy this from Tools > Publish.

Oy, do it the oldfashioned way

Add a search feature

| Add Layer |

2. Set map size and zoom

Zoom and pan the preview map as you'd like it to
appear.

Atlantic
Ocean

Map data @2012 MapLink, Tele Atlas - Terms of Use

Dimensions: Width: [soo | px, Height: [400 | px

| Update Map |

Then click the Add Layer button and repeat the process for the map of
Ramsar Convention sites.

Under Set map size and zoom, change the Dimensions to fit your website,
then click the Update Map button. Use the controls on the map to adjust the
position and zoom of the map to the appearance you want:

Under Style base map, you can remove unwanted features from the Google
Map.


http://fusion-tables-api-samples.googlecode.com/svn/trunk/FusionTablesLayerWizard/src/index.html

When you are finished, you can copy the code in the box at the bottom of the
wizard into the html for your webpage. To see how this works, click in the
Your HTML box and Ctrl-A, Ctrl-C to select and copy the code. Open the
Notepad text editor and Ctrl-V to paste in the code.

Save the file as type All Files, with the extension .html and UTF-8
encoding.

File name: amphibians.html -
Save as type: |A|I Files v|
4« Hide Folders Encoding: |UTF-E v| | Save | | Cancel |

Now open the file in a web browser to view the map.

Ready for more?

The Layer Builder can only add two layers, but you can make Fusion Table
maps with up to five. To do this, you’ll need to study the code and work out
how to add more layers yourself — it’s not so difficult.)

Tip! This is where the maps' Ids come in. Notice that they appear in the
html code written by the Layer Wizard. If you are adding layers by
writing the code yourself, you will need the tables’ Ids.

You can also write code to include a legend. Study the html code for the
finished map to see how this can be done.

More examples of Fusion Table maps:

For inspiration, see the gallery at:
https://sites.google.com/site/fusiontablestalks/stories
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