THEMATIC MAPS WITH GOOGLE FUSION TABLES

(Data for this tutorial at www.peteraldhous.com/Data)

Journalists often want to create thematic web maps, in which geographic
areas are filled in with color/shade according to data values, for example:
http://www.texastribune.org/library/data/census-2010/

Thanks to Google Fusion Tables, creating basic thematic maps and
embedding them on a web page is now easy. First we need to be logged in at
http://www.google.com/fusiontables/Home with a Google account.

We’re going to create a map illustrating the intensity of violent crime in
Chicago.

First we need a map defining the boundaries of the 77 Community Areas that
make up the city, downloaded as a “shapefile” from
https://data.cityofchicago.org/Facilities-Geographic-Boundaries/Boundaries-
Community-Areas/i6Sm-w5{r in the zipped folder CommAreas.

Shapefiles are a format used in Geographic Information Systems (GIS).
They consist of a series of files, one of which (with the extension .dbf) is a
table of data. Shapefiles can be obtained from various sources; here’s a good
general library: http://www.naturalearthdata.com/downloads/.

This map 1s already in Fusion Tables. However, if you need to upload a
shapefile, go to http://shpescape.com/ and upload the zipped folder (there’s
no need to use the Advanced Options). Geographic boundaries in KML
format, used by Google Earth, will upload directly.
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Open the uploaded shapefile (at http://bit.ly/J4ueFL). You should see a
screen like this:

CommAreas.shp
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Click the little button with the triangle near the top right to scroll across to
see the other columns in the table.
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See that each Community Area has a number, in the fields beginning

AREA_NUM, which we’re going to use later to pull in the crime data that
we’re going to map.

We can now close this table using File>Close in the top menu.
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The crime data is in the spreadsheet 2011 Chicago violent crime and
population.xlsx; the numbers came from a search of a year’s violent crime
incidents at http://gis.chicagopolice.org/ and the Chicago Tribune’s analysis
of the 2010 US Census.

Note that in this spreadsheet each Community Area has an ID, which
corresponds to the AREA_NUM fields in the shapefile.

A B C D E F G
Violent crimes per
1000 people
1 ID Community area Population (2010} Violent crimes (2011) (2011}
2 1 Rogers Park 54991 453 8.24
3 2 WestRidge 71942 262 3.64
4 | 3 Uptown 56362 341 6.05
5 | 4 Lincoln Square 39493 93 2.35
6 5 Morth Center 31867 67 2.10
7 b Lake View 94368 457 4.84
8 | 7 Lincoln Park 64116 229 3.57
9 8 Mear North Side 30434 596 7.41
10 9 Edison Park 11187 3 0.27
11 10 Norwood Park 37023 37 1.00
12 11 Jefferson Park 25448 41 1.6l
13 12 Forest Glen 18508 15 0.21
14 13 MNorth Park 17931 55 3.07
15 14 Albany Park 51542 230 4.46
16 15 Portage Park 64124 245 3.82
17 16 Irving Park 53359 292 5.47

We’re later going to color the Community Areas according to the data for
Violent crimes per 1000 people (2011). Sorting the data in the spreadsheet
we can see that this peaks at 51.33 for Fuller Park.


http://gis.chicagopolice.org/

Back in Fusion Tables import the spreadsheet by clicking on Create>Table.
At the first dialog box, select From this computer, and hit Choose File:

Import new table

|| From this computer Choose File | No file chosen

E Google Spreadsheets “f'ou can upload spreadsheets, delimited text files (.csv, tsv, or .txd),
and Keyhole Markup Language files (.kml} Learn more

Ell Create empty table

Cancel Next »

Select your spreadsheet, click Next, and again at the second dialog box:

Import new table

Specify the columns to import.

Column names are in row | 1 |Z|

Import i
Violent
1 D Community Population Violent crimes per
area (2010) crimes (2011) 1000 people =
(2011)
2 1 Rogers Park 54991 453 8.24
3 2 West Ridge 71942 262 3.64 M
4 3 Uptown 56362 A 6.05
5 4 Lincoln 39493 93 235
Square
6 5 Morth Center 31867 67 2.10
7 6 Lake View 94368 457 4.84
8 7 Lincaln Park 64116 229 3.57 -
Rows before the header row wil be ignored.

Cancel  «Back |MNext»



If you wish, you can add some notes about your spreadsheet at the third
dialog box, then click Finish and it should load.

Next we’re going to format the data so it displays nicely on our map. Select
Edit>Modify columns from the top menu. For the two numeric fields we’re
going to map, set the format as follows, so we get a comma to separate
thousands in the Population (2012) field and don’t have too many trailing
decimal places for the Violent crimes per 1000 people (2011) field.

Configure columns

Table Columns Column Details
D Mumber | Column name:
Population (2010
Community area Text opLEnen | )
. Type:
Population (2010
¢ ( ) MNumber E
Violent crimes (2011) MNumber
Format:
Violent crimes per 1000 people Mumber 1,234 .56 |z|
(2011)

Save | Cancel

Hit the Save button.



Before we can make our map, we need to join the two tables together. Still in
the uploaded spreadsheet, select Merge from the top menu.

Merge with another table

1 Choose the column to use for matching data 2 Merge with

across the two tables
Get

Enter a table name, IO, or URL

2011 Chicago wiolent crime and population.xlsx

@ 1D

= Community area

= Population {2010)

- Violent crimes (2011)

= Violent crimes per 1000 people {2011)

[l Select subset of columns [[| Select subset of columns

Save as a new table named

The merged table will be computed dynamically from the two base tables, using the rows from the first
table. Changes to the base tables will be reflected in the merged table and vice versa

Merge tables Cancel

If you click in the Merge with box, you should get the option to select your
own tables. We want to merge with the CommAreas shapefile, which we can
select by entering its URL, or its ID number: 680103. (To find the ID of a
Fusion Table, select File>About.)



Select the ID field in on the left and one of the AREA_NUM fields on the
right to join the tables on these fields. Check the Select a subset of columns
checkbox for each tables, to import only those fields we want to use. From
the shapefile, we need only select the geometry column, which will be used
to draw the map. Add a name for the new table and then hit the Merge
tables button at bottom left.

Merge with another table

1 Choose the column to use for matching data 2 Merge with

across the two tables EA0103 Get

Enter a table name, 1D, or URL

2011 Chicago viclent cime and population_xlsx CommAreas.shp
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Save as a new table named 2011 Chicago Crime and Population Map

The merged table will be computed dynamically from the two base tables, using the rows from the first
table. Changes to the base tables will be reflected in the merged table and vice versa

Merge tables Cancel



Now we can start mapping. Select Visualize>Map in the top menu. Click on
the Configure info window contents link. This is where we define what
goes in the bubbles that appear when someone clicks on the map.

In the Automatic tab, uncheck 1D, as we don’t want this field to appear.
Then select the Custom tab and we’ll do some edits in the html code, adding
some line breaks using <br> tags:

Change info window layout

Automatic Custom
Write the HTML for your info window with column placehalders like {column name}. Learn more

1D <diwv class="'googft-info-window' =style='font-family: sans-serif'>
<b>Community area:</b> {Community areal<br><br>

Community area <b>Population (2010):</b> {Population (2010)}<br><br>

Population {2010) <b>Violent crimes per 1000 people (2011) :</b> {Violent crimes
§ . per 1000 people (2011) i<br>

Violent crimes per 1000 </div>

people (2011)

geometry

Save Cancel

Hit the Save button.



Now let’s color the areas according to their intensity of violent crime. Click
the Configure styles link, select Polygons>Fill color, and select the
Buckets tab.

In this tab select Violent crimes per 1000 people (2011) as the Column to
map. It’s worth experimenting the number of buckets and the splits between
them to give the best display for your data. In this case we’ll Divide into 5
buckets and type in 60 as the maximum value at the bottom.

Then we can select a color scheme, also selecting 75% for opacity so the
colors stand out nicely from the Google map.

Change map styles

Points
Polygon background colors
Marker icon
Fixed Column Buckets Gradient
Polygons
Fill color g
{*) Divide into | 5 ~ | buckets
Border color
Column | Viclent crimes per 1000 people (2011)
Border width
bl + 0.0 up to 12.0 n
Line color +||-| 12.0 up to 24.0 #fdccoe
Line width +||-| 24.0 up to 36.0
+||=-| 38.0 up to 48.0
+ (| =| 48.0 up to 60.0
60.0

Opacity 75 %

Cancel



Hit the Save button, and here is the thematic map:

Before we can embed the map on our website, we need to make it visible to
the wider world by clicking the Share button at top right and selecting
Public under Visibility options.



The simplest way to embed the map is to click Get embeddable link, and
change the width and height from the defaults to the appropriate size for
your website. You can then select and copy the embed code and paste it into
the html of a webpage.

2011 Chicago Crime and Population Map
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Showing all rows options

Location [ geometry *| [JDisplay as heat map Configure info window Configure styles Export to KML Get KML network link Get embeddable link

<iframe width="500" height="300" scrolling="na" src="https://www.google.com/fusiontables /embedviz?
viz=MAP&q =select+col 0¥3EX3IEL+from+ 3636437 +&h=false&lat=41.81463011081473&Ing=-87.766457 8685
90638z =10&1t=1&|=col0%¥3E%3EL"> < /iframe>

A

However, we’ll obtain a nicer embed, and also be able to customize the
Google map, if we use the Fusion Tables Layer Wizard.

Get the ID number for the table by selecting File>About, then go to the

wizard at: http://gmaps-
samples.googlecode.com/svn/trunk/fusiontables/fusiontableslayer builder n

ew.html

Paste in the table ID, select geometry as the location column, and hit the
Add layer button. At this point we have to zoom the Preview map into
Chicago, and then add the dimensions for the embed and hit the Edit map
button.
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The layer wizard also allows you to add a second layer (for example
mapping points over the top of a thematic map), and lets you add a box to
isolate a particular area or point by making a selection or with a text search.

Under More options under Style Map, you can remove unwanted features
from the Google Map. If you really want to go to town in styling our map
you can also use the Google Maps API Styled Map Wizard (http://gmaps-
samples-v3.googlecode.com/svn/trunk/styledmaps/wizard/index.html) to
obtain the code necessary to make further changes. Beware, however, that
styling a Google Map greatly reduces the usage limits before which Google
may pursue you for charges, see
https://developers.google.com/maps/faq#usagelimits. So if your map may
get a lot of traffic, it’s best not to use the styling options. (Unstyled maps are
unlikely to exceed usage limits, except on very busy sites.)

When you are finished, copy the code in the box at the bottom of the wizard
into the html for your webpage.
Examples:

For inspiration, see the gallery at:
https://sites.google.com/site/fusiontablestalks/stories

More tutorials:

Google’s tutorial on making a thematic map:
http:// www.google.com/support/fusiontables/bin/answer.py?
hl=en&answer=1032332

How to map points (latititude and longitude, addresses etc), and to display as
a heat map revealing the density of points, if you have lots of them:
http://earth.google.com/outreach/tutorial fusion yourowndata.html

More on ways to embed/share a map:
http://earth.google.com/outreach/tutorial fusion publish.html#embedmap?2
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